Installation

Aiodynamo requires Python 3.7 or higher.

Aiodynamo requires an HTTP client to function, but abstracts the client away. You can either use one of the built-in adaptors for aiohttp or httpx, or use your own client by writing an adaptor for it.

If you wish to use the aiohttp adaptor, install aiodynamo[aiohttp], for httpx use aiodynamo[httpx].

Aiodynamo uses CalVer, not semantic versioning. Make sure to check the Changelog before upgrading.